Introduction to PyMOL

General Introduction ................................................................. 2
Layout and Features ........................................................................ 2
Basic Mouse Controls .................................................................... 4
Visualization Presets ..................................................................... 7
Making Measurements ............................................................... 9
Saving Images ................................................................................ 10
Saving and Restoring Sessions .................................................... 11
Representations and Selections .................................................... 12
Controlling Representations ....................................................... 12
Understanding and Creating Selections ...................................... 12
Using the Sequence Viewer .......................................................... 14
Viewing a Prepared PyMOL Session ............................................ 16
Loading the Kinase Demonstration Session ................................. 16
Working with Multiple Objects ..................................................... 19
Alignment Based on Protein Sequence ........................................ 19
Alignment Based on Specific Atomic Pairs ................................. 20
Creating and Editing Molecular Objects ....................................... 21
Removing Unwanted Atoms .......................................................... 21
Changing Bond Valences ............................................................. 21
Rotating Bond Torsions ............................................................... 22
Creating or Removing Bonds ....................................................... 22
Creating One Object Out of Another .......................................... 22
Mutating Protein Residues .......................................................... 22
Building Small Molecules ........................................................... 23
Scenes and Shows .......................................................................... 24
Creating and Viewing Scenes ...................................................... 24
Modifying, Annotating, and Saving Scenes in a Session .............. 24
Creating Shows and Interconverting with Sessions ...................... 24
Advanced Features .......................................................................... 25
Saving Coordinates ........................................................................ 25
Probing Electrostatics ................................................................. 25
Atom Selection Syntax ............................................................... 26
Automating with Scripts ............................................................. 26
Creating Movies ............................................................................ 27
Next Steps .................................................................................... 29
Joining the PyMOL–Users Mailing List ....................................... 29
Visiting the PyMOL Wiki Community Web Site ......................... 29
Accessing the Online Manuals .................................................... 29
Installing PyMOL ............................................................................ 30
Precompiled Executable Builds .................................................... 30
If you have a Windows PC .......................................................... 30
If you have a Macintosh .............................................................. 31
If you have a Linux PC .............................................................. 32
**Introduction to PyMOL**

This tutorial introduces you to the basics of using PyMOL with coverage of the Windows, Linux, and Macintosh versions. It also covers aspects of the program likely to be of use in medicinal chemistry, such as visualizing protein–ligand interactions, working with prepared session files, and creating figures.

Though PyMOL can be quite effective for certain visualization tasks, it has a lot of "rough edges" and will frustrate you at times with its limitations and complexity. When you get discouraged, please remember that this is a community–driven work in progress that will improve over time, especially with the benefit of your input. When you see simple ways in which PyMOL could be enhanced, please share those ideas via the mailing list. The following summary should help you understand the strengths and weaknesses of the package and help you set some realistic expectations for its use:

**What is currently good about PyMOL?**

- Powerful and interactive molecular visualization.
- Publication−quality image output.
- Session files enable you to share content with others.
- Show files are suitable for meetings and live presentations.
- Scripting enables automation of routine tasks.
- PyMOL can be integrated with in–house information systems.
- The PyMOL open−source project has significant community momentum.

**What is currently bad about PyMOL?**

- It can be hard to learn.
- It has a primitive and quirky user interface.
- It is unforgiving of mistakes (there is no general "undo" capability).
- Typed commands are still often required for common tasks.
- Documentation is currently limited and sometimes obsolete.
- The molecular building and modeling tools are incomplete.

**Copyright Notice**

This Tutorial is Copyright (C) 2006 DeLano Scientific LLC. All Rights Reserved. Unauthorized reproduction or dissemination is prohibited under United States and international copyright laws.

"Introduction to PyMOL" is a PyMOL Incentive Product created for the exclusive use of PyMOL Subscribers who sponsor the effort financially. Unrestricted distribution of this material could jeopardize the financial integrity of the PyMOL project, so please DO NOT POST THIS DOCUMENT IN AN INSECURE OR PUBLICLY ACCESSIBLE LOCATION. Current PyMOL Subscribers may only distribute copies of this tutorial internally to users within their organization who are covered by the scope of the subscription.

If you come into possession of an unauthorized copy of this document, please either delete it or contact sales@delsci.com to purchase an appropriate PyMOL Subscription to cover your usage.
General Introduction

Due to its cross–platform heritage, PyMOL does not behave like standard Windows or Macintosh applications, so it takes some extra effort to learn. However, once you get past the initial learning curve, you should be able to efficiently perform a variety of common molecular visualization and manipulation tasks. Also know that time invested in learning PyMOL today will yield lasting benefit thanks to PyMOL’s cross–platform support and open–source license, which guarantee that versions of PyMOL will remain available to you in the future, regardless of your computer’s operating system, your financial resources, or where your career takes you.

Layout and Features

For various technical reasons, the PyMOL user interface is split over two areas which look and behave somewhat differently. The upper area should feel relatively familiar in that it contains a menu bar, buttons, and text fields. In contrast, the bottom area contains buttons, toggles, pop–up menus, and interactive graphics that are unique to PyMOL and which may work differently from what you expect.

The External GUI Area

The top area is known as the "External GUI". Note that GUI stands for "graphical user interface" as distinct from command–based user interfaces. The External GUI contains the "File" menu and other useful menus, a multi–line output field where PyMOL diagnostic information is displayed, an input field where you can copy and paste PyMOL commands, and a set of buttons for controlling the overall display. Note that the External GUI will look different depending on your operating system.
The PyMOL Viewer Window

The bottom window, the "PyMOL Viewer", contains the "Internal GUI", which consists of the controls and information presented on the right–hand side of the window. The Internal GUI contains a list of names for all objects and selections, and enables you to toggle the display of named entities as well as change how they are individually represented via "pop–up" menus. Also present in the viewer window is a block of mouse configuration information, a tab for expanding the internal GUI, VCR movie control buttons, and a secondary command line.

Built–In Demonstration Wizard

PyMOL contains a small set of demonstrations that can give you a taste of what the software is capable of doing. To launch this demonstration wizard, select "Wizard" from the External GUI menu bar, then "Demo" and "Representations". To view the other demonstrations, click on the buttons in the Internal GUI on the right–hand side of the PyMOL Viewer Window.

Loading a Molecule via the File Menu

Of the menus that exist in the External GUI, the only one you need to familiarize yourself with right now is the "File" menu, which contains the "Open..." item that can be used to load molecular content into PyMOL.

For starters, try opening the Protein Data Bank (PDB) file "1t46.pdb" from the "kinases" folder of this tutorial. Information loaded from the PDB will appear in the text output field, and your window should now look like
Basic Mouse Controls

Many different tasks are performed using the mouse in PyMOL. Of course, that means there is a lot to learn and remember, so here is a gentle introduction to controlling PyMOL using the mouse. Note that a three–button "wheel" mouse is required, so please obtain one before continuing with this tutorial.

Buttons: Pressing Down and Dragging the Mouse

Assuming that you have loaded a PDB file into PyMOL, please take a moment to familiarize yourself with the behavior of the three mouse buttons by separately pressing and holding each button down in the graphics area and then dragging the mouse. If you get lost, simply click the "Reset" button in the External GUI.

Note that with a "wheel" mouse, the act of pushing down on the wheel is distinct from that of rolling the wheel. For now, please simply treat the wheel like a middle button by pressing down on it (into the table) and dragging the mouse.

Did pink dots or a white globe appear? If you click–and–release the left button quickly without dragging the
mouse, then some pink selection dots or a white globe may appear on the screen. To get rid of them, just click and release the mouse on a blank portion of the graphics area away from any atoms. We'll discuss what these mean later on.

Is "Caps Lock" down? It shouldn't be. When Caps Lock is enabled on your keyboard, PyMOL’s mouse controls will not work properly. If the mouse is not behaving as described here, please check to make sure that the Caps Lock key is not pressed.

PyMOL’s Virtual Trackball

By now you have noticed that when you drag using the left button in the graphics area, PyMOL rotates the molecule. However, you may not have noticed that the nature of the rotation depends on where the cursor is located when you press the button.

For simple rotation about an axis located in the plane of the screen, always move the cursor along a straight line that passes through the center of the graphics area. In contrast, for rotation about an axis perpendicular to the screen, click and drag along one of the far edges of the graphics area. Moving the mouse in an intermediate path between these two extremes will generate a mixed result, and enable you to rotate the molecule about any axis you wish.

To understand what is going on, imagine what would happen if you took your index finger, touched it against a heavy bowling ball, and then moved your finger in some arbitrary direction while keeping your finger on the ball. If you moved your finger in a path through the top of the ball right in the center, then the ball would simply roll in the same direction as your finger. However, if you touched the side of the ball, then the ball would tend to spin somewhat about its vertical axis while at the same time rotating. That is essentially how PyMOL’s virtual trackball works.

The virtual trackball enables you to rotate the camera in precise and sophisticated ways. However, if do not like this default behavior, then you can disable the virtual trackball by deselecting "Virtual Trackball" in the Mouse menu. Rotation will then be restricted to axes residing in the XY plane of the screen.
Clipping and Centering with the Scroll Wheel

Please click the "Reset" button in the External GUI to restore the original view of your molecule. (If you are using Linux or Windows, please reactivate the viewer window by clicking on the "PyMOL Viewer" title bar).

Now try rolling the mouse scroll wheel backwards, towards you. What happens? Various portions of the molecule should disappear from both the front and the back of the molecule. Now roll the scroll wheel in the reverse direction, forwards, away from you. Portions of the molecule that previously disappeared should now reappear. You have now learned the simplest way to control "clipping" in PyMOL, which gives you the ability to focus in on interesting areas of your molecule while hiding everything else from view.

Now please use the scroll wheel to adjust the thickness of the "clipping slab" to that shown to the right, where you can see approximately one single layer of amino acids. Then try rotating, panning, and zooming using the left, middle, and right buttons respectively. With a little practice, you should now be able to visualize and focus in on individual portions of the structure, for example the helix shown below.

If you hold down the Control or Shift keys while rolling the scroll wheel, then PyMOL will translate the molecule relative to the slab, or the slab relative to the molecule, respectively. In other words, if you hold down Control (CTRL) and roll the wheel, it will appear as if the molecule is moving toward you or away from you. If you hold down Shift, then the molecule will not appear to move, just what is visible will change. Please try these actions now.

The next useful action to learn is "centering", which involves clicking and releasing the middle/wheel button while the cursor is hovering over an atom. When you do this, PyMOL will then move the clicked atom to the center of the screen as well as to the center of the clipping slab. This action enables you to navigate through a structure simply by clicking on the next atom of interest. Try moving about the structure just by clicking the middle button on one atom after another.

Sometimes the scroll wheel does not provide sufficient granularity in positioning of the clipping planes, so there is an alternative clipping mechanism available that involves holding down the Shift key and the right mouse button simultaneously. Dragging the mouse vertically will then move the front (near) clipping plane and dragging the mouse horizontally will move the back (rear) clipping plane. For more information on this feature, please consult the PyMOL Users Manual.
Visualization Presets

For most common PDB files, PyMOL can provide you with a set of built-in "preset" views. These are accessed via the Actions ("A") pop-up menu in the Internal GUI.

Assuming that you have loaded a PDB such as "1t46.pdb" from the "kinase" folder, click on the "A" next to the name of the object and follow the cascading menus to the "preset" sub-menu and then the "simple" item. Once you select this preset, PyMOL will apply a treatment to the molecule that should result in a simplified view of the protein structure with ligands displayed (if any are present).

For example, applying the "simple" preset to "1t46" should make it possible for you to spot the ligand Gleevec, and you can then use your mouse skills to zoom in on it for a closer look as shown below.
PyMOL contains a number of presets that can be of immediate use to you in visualizing protein / ligand complexes as well as in preparation of several common types of figures. For example, the "ligands" preset enables you to visualize the polar contacts made between the protein and the ligand.

Once you have applied the "ligands" preset, you can toggle the display of polar contacts by clicking on the "1t46_pol_conts" name. With polar contacts enabled, you can also display the distance values by clicking on the Show ("S") pop-up menu next to "1t46_pol_conts" and selecting "labels". Likewise, click on the Hide ("H") pop-up menu and select "labels" to hide the distance values.

Other presets worth trying at this point include: "technical", "ligand sites" → "transparent surface", and "publication". Please restore the "default" preset before continuing on to the next section.
**Making Measurements**

PyMOL can be used to measure distances, angles, and dihedrals. The easiest way to do this is via the Measurement Wizard, which can be activated by going up to the "Wizard" menu and choosing "Measurement".

Wizards work by prompting the user to perform a given action and typically provide some controls on the right-hand side of the Internal GUI. By default, the Measurement Wizard is configured for measuring distances between two atoms. You can do this by simply clicking on the first atom and then the second, and then repeating the process as needed. To measure angles or dihedrals, click on the "Distances" pop-up menu and select "Angles" or "Dihedrals" instead. Then pick sets of 3 atoms each for angles, and sets of 4 atoms each for dihedrals.
If you make a mistake measuring a distance, you can click on the "Delete Last Object" button to delete the last measurement object created. You can also delete all measurements by clicking "Delete All Measurements".

By default, each new measurement is loaded into an object of its own. If instead you would prefer to place all new measurements into a single object, then click on the "Create New Object" and select "Merge With Previous" before making the measurements.

One common use of the Measurement wizard is to create a dashed bond between two atoms without any label for the distance value. To eliminate the label for a measurement, click on the Hide ("H") button for the measurement object and choose "labels".

When you are done making measurements, click the "Done" button to close the wizard. Please click "Done" before continuing on with the next section.

**Saving Images**

To use your PyMOL image in a PowerPoint presentation or a publication, you can save it as a Portable Network Graphics "PNG" image file. PNG files can be read by Microsoft PowerPoint, Microsoft Word, and many other commonly used programs.

To save an image, first set up the view that you want in the PyMOL graphics window. Then select "Save Image..." from the "File" menu in the external GUI and choose a suitable destination and name for the file. Once the file has been saved, you can then import the image into PowerPoint by going up to the "Insert" menu in PowerPoint and selecting "Picture" and then "From File...".

One of the extra conveniences of MacPyMOL is that it supports direct copy and paste an images into external programs, such as Keynote or PowerPoint. You can copy the image either via the "Edit" menu or by holding down the Command key and pressing the C key. Then switch applications and paste the image in.

**Raytracing for Better Quality**

PyMOL has a built−in renderer for raytracing that can eliminate rough edges, generate better lighting effects, and cast shadows. However, depending upon the complexity of the scene, use of this renderer can be rather time consuming, sometimes requiring several minutes to create a single image.
normal −> <= ray−traced

To render a scene before saving the image, simply click on the "Ray" button in the external GUI before proceeding as described above. A progress indicator should appear.

**Controlling Image Resolution**

By default, PyMOL images are saved at screen resolution with a width and height equal to that of the graphics area. To save images of a higher resolution, you must either expand the size of the viewer window or use the "draw" or "ray" commands to explicitly set image resolution.

For example, to generate a 4 inch by 3 inch image at 300 dots per inch (1200 by 900 pixels), one would need to enter one of the following commands into the PyMOL command line before saving the image:

```
draw 1200, 900
ray 1200, 900
```

The first command renders using OpenGL, which is usually quite fast. The second command uses the raytracer, which can be rather slow, but generates better images.

**Saving and Restoring Sessions**

You can save a PyMOL Session File any time while you are using PyMOL. These sessions contains all of structures you have currently loaded into PyMOL and all of the information about how to display them, including the colors, representations, and camera view. When you reopen a session file, you can continue your work right from where you left off. Be sure to save the session file again when you are done in order to record any subsequent changes.

To save a PyMOL session, select "Save Session As..." from the File menu, choose a suitable location and name for the file, and then click "Save". PyMOL session files must be given a ".pse" file extension so that PyMOL can recognize them later on.

On Windows and Macintosh computers, you can open session files simply by double−clicking on the session file icon. Or, if PyMOL is already open, then you can use the "Open..." item in the File menu in the External GUI.

**Using Session Files In Place of Undo**

Because PyMOL does not contain a general "undo" capability, the user needs to act defensively against mistakes by saving session files often, thus securing a means of returning to a previous state without having to start over from scratch. To avoid frustration, please get into the habit of saving session files every five minutes when using PyMOL for extended tasks.

As an alternative approach, many advanced users choose to use PyMOL scripts and Python programs to drive the package through complex procedures, since such scripts can often be reused later with other projects.
Representations and Selections

Controlling Representations

PyMOL's presets automatically provide a few common views of a molecule, but it is often necessary for the user to take greater control over the molecular representation process in order to achieve desired visualizations.

Representations can be controlled using the Show ("S"), Hide ("H"), Label ("L"), and Color ("C") pop-up menus. Every object has its own set of these pop-up menus, as does each selection that the user has defined.

When you use a Show or Hide menu for an object, all of the atoms within that object are affected by that action, and the changes are cumulative. For example if you show "sticks", show "spheres", and then show "dots", then all atoms in the object will have all three representations active at once. If you then hide "spheres" and hide "dots", then only the sticks representation would remain visible.

The show menu has a special "as" sub-menu which enables you to hide all other representations while showing just the representation you indicate. For example, if you show "as" → "sticks", and then show "as" → "dots", only the dots representation would remain visible. Please take a moment now to try using the show and hide pop-up menus. Note that the "surface" and "mesh" representations will take some time to compute for larger molecules.

At the top of the names list, there is the "all" entry, which enables you to apply actions to all objects currently loaded into PyMOL. For example, if you wish to hide all representations of all objects, you can choose "everything" from the hide ("H") pop-up menu next to "all".

Understanding and Creating Selections

When working with molecular structures, it is often the case that you want to show one part of a structure using one representation, and another part using a different representation. PyMOL's atom selections make it possible for you to do this by enabling you to apply various operations to specific subsets of atoms within one object or even across multiple objects.

Selections behave simply as lists of atoms and do not have any properties of their own. Named selections appear by name in the Internal GUI enclosed by a set of parentheses "( )" in order to distinguish them from object names. For example, when you begin using PyMOL, the selection you create using the mouse will have the name "(sele)".
Atoms contained in the active selection are displayed in the viewing area with little pink dots or rectangles overlaid right on their atom centers. Only one selection can be active at a time, and the active selection is highlighted in the names list. Clicking on the name of the active selection will deactivate it and hide the pink dots. Clicking on the name of an inactive selection will make that selection into the active selection.

**Mouse Modes and Selection Modes**

In order to create selections using the mouse, the Mouse Mode must be set to "3−Button Viewing", as indicated in the center of the Internal GUI on the right hand side of the viewer window. If this is not the current mouse mode, then you can set it by selecting "3 Button Viewing Mode" from the "Mouse" menu in the External GUI or by simply clicking once on the Mouse Mode indicator in the Internal GUI.

By default when in 3−Button Viewing mode, PyMOL will select the complete residue you click on, or de−select it if it is already in the current selection. The "Selecting Residues" message in the Internal GUI indicates that selections are currently being made on a per−residue bases. Other possible mouse selection modes include selection of individual atoms, molecules, chains, segments, objects, and C−alphas. To change the current mouse selection mode, either use the "Selection Mode" item under the "Mouse" menu in the External GUI, or click on the "Selecting ..." indicator in the Internal GUI.

**Renaming Selections**

The default names given to selections in PyMOL are not informative, so it is often helpful to rename selections you have made to something meaningful. To do this, click on the Action ("A") menu next to the selection name, select "rename selection", and then enter the new name using the keyboard.

**Using Selections**

Once you have created a selection, you can use the menus located next to the selection name to change its representation. For example, the show "sticks" action was used on the above selection to give the result shown below.
Existing selections can be modified in a variety of ways to include additional atoms or to exclude atoms already in the selection. You already know that selections can be modified by clicking on atoms. Alternatively, one can use the "modify" sub−menu within the Action ("A") menu for a given selection in order to perform a variety of actions based on geometric and other criteria. For example, choosing "modify" → "expand" → "by 6 A, residues" in the Action menu for a selection will expand the selection to include all atoms in all residues that exist within 6 Angstroms.

Selecting using Commands

One can also create selections using typed−out commands. For example, to create a selection named "my_sele" covering residues 810 through 812 of chain A, one could enter the following command:

select my_sele, A/810−812/

Using the Sequence Viewer

PyMOL can display residue sequences for molecular objects in the graphics area. To activate the sequence viewer, click on the "S" in the lower right−hand corner of the Internal GUI or select "Sequence" from the "Display" menu of the External GUI. If the molecule is a protein, then the one−letter code for the residue type will be used by default. Otherwise, the full residue name will be shown, as is usually the case for ligands.

The sequence viewer provides another means of visualizing and manipulating the active selection. Selected residues are shown in inverted colors in the sequence viewer, and selections can easily be modified by clicking and dragging on the sequence characters.
Right-clicking directly on the selection in the sequence viewer will bring up a menu of actions that will be applied directly to that selection. This menu provides an alternative means of altering representations for a given selection of atoms. This same context-sensitive menu can also be obtained by right-clicking on a selected atom in the 3D graphics area.

If you instead right-click on an unselected atom in the sequence viewer, then a different menu will appear. This menu is titled with identifying information for the residue you clicked on and enables you to perform various actions, such as changing colors or altering representations for the residue. When you right-click on an unselected atom in the 3D graphics area, a similar menu will appear, but this menu gives you the additional option of applying actions to the atom, residue, chain, segment, object, or molecular level.
Viewing a Prepared PyMOL Session

If you work within a pharmaceutical or biotech company, then there may be computational chemists, crystallographers, or even automated systems that will prepare PyMOL content for you in a standardized fashion. Normally they would generate PyMOL sessions in an automated or semi-automated manner using PyMOL script files and then share the resulting session files with you. Alternatively, they may provide web-based or Java-based tools that can export content for you directly into PyMOL. Either way, the following example illustrates some of what can be done using PyMOL with prepared content.

Loading the Kinase Demonstration Session

Included with this tutorial is a sample session file "kinases.pse" which contains six kinase structures that have been organized for easy perusal. When you open this session file, your screen should look like this:

In the graphics display area you can see the structure of Phosphoinositide-Dependent Kinase 1 (PDK1) complexed with the inhibitor Staurosporine. The structure you are viewing is Protein Data Bank (PDB) structure 1OKY, and you can see that all four active objects in the internal GUI start with the prefix 1OKY.

Try turning the 1OKY objects on and off individually. You should notice that display of the protein, the inhibitor, the solvent, and hydrogen bonds can all be controlled independently. Also note that you can click and drag downward to toggle display of multiple objects at once.

Disable all of the objects except "1OKY_prt" and then enable object "1ZSM_prt", which is another crystal structure of PDK1 but with a different ligand. From this view, you can observe that while the chemical
structures are the same, the two structures differ in the precise orientations of various side chains. If you then enable "1OKY_inh", "1OKY_hbd", "1Z5M_inh", and "1Z5M_hbd", you will be able to see how the two ligands interact differently with PDK1.

Note that there are four atom selections listed at the top of the Internal GUI: (inhibs), (prots), (solv), and (sites). You can toggle these selections individually to visualize which atoms are included in each selection. These selections are useful for changing the way various groups of atoms are represented across all complexes in the session.

For example, the "(sites)" atom selection can be used to selectively display a transparent molecular surface on each protein covering the active site. To do this, first disable all but one of the protein objects, for example, 1T46_prt (V−Kit). Then go to the Show ("S") menu next to the (sites) selection and select "surface". A molecular surface will then appear on the "1T46_prt" object. If you enable the other 1T46 objects, you can then use the scroll wheel and centering actions to visualize Gleevec inside its binding pocket as shown below.
To remove the surfaces, simply Hide ("H") the surface representation for the (sites) selection. Likewise, you can use the (inhibs) selection to change how the inhibitors are displayed. For example, try showing spheres for the (inhibs) selection in order to obtain a space–filling view of the inhibitors.

One of the special things about this particular session file is that ligand valences have been explicitly defined, which means that you can visualize bond orders while studying the interactions. To activate bond valences, select "Show Valences" from the "Display" menu in the External GUI.

You can always use session files such as this as starting points for your own customized figures, where you control the representations of each object individually, as was done below in showing three kinase structures as cartoons with ADP represented as a surface. If you get lost or make a mistake, you can start over by quitting PyMOL and reopening the original session.

Please spend some time experimenting with this session file until you feel quite comfortable with it.
Working with Multiple Objects

Provided that your computer system has sufficient memory and processing power, PyMOL can be used to visualize and compare up to several dozen structures simultaneously.

Multiple structures can be opened sequentially using the File menu, but this can be tedious if there are a lot of files to load. On Windows and Macintosh systems, multiple PDB files can be dropped directly onto the PyMOL icon at launch in order to open them together. Alternatively, one can use a script to load multiple files using the "load" command. Recent versions of PyMOL now include a "fetch" command that can be used to load one or more structures directly from the protein data bank using PDB identifiers.

fetch 1t46 1oky 1z5m

As a first step to performing structural comparisons, it is usually necessary to superimpose the structures onto a common template. PyMOL can perform superpositions based on protein sequence, based on paired selections, or manually based on clicked atom pairs.

Alignment Based on Protein Sequence

Recent versions of PyMOL include the ability to perform protein structure alignments via the Actions ("A") menu of objects and selections. For example, if two or more related proteins structures are loaded, one can click on Actions "align" -> "all to this" to automatically align all of the other protein structures loaded on to the indicated protein. Likewise, individual proteins can be superimposed via Actions "align" -> "to molecule" -> followed by the name of the target molecule object.

Finer control over the alignment process can be exercised by creating selections that represent the two regions to be aligned. In this case, one selection (e.g. sel01) should be created in the target molecule and a second independent selection (e.g. sel02) should be created in the molecule to be aligned. Then one could click on the Actions menu of (sel02) "align" -> "to selection" -> "sel01" to perform a superposition based on only those two regions.

Alignments performed as above using the menus are based on protein sequence followed by an interactive structure superposition, and only the CA atom positions are considered.

Greatest control over alignment can be exercised by entering an "align" command via the command line. For example, the kinase structure "1uwh" actually contains two copies of the enzyme, chains A and B, whereas "1t46" only contains one copy. The default alignment between "1t46" and "1uwh" matches only the B chain. To force alignment of 1t46 against the "A" chain of "1uwh", one could enter the following command:

align 1t46///CA, 1uwh//A//CA
Alignment Based on Specific Atomic Pairs

Sometimes a local superposition over a few key residues is preferable to a global superposition. For example, with the two kinase structures "1uwh" and "1t46", one could imagine just wanting to superimpose a few residues in the ligand binding site. However, this task is often complicated by the fact that residue numbering may not match from one structure to another, as is the case here, so the user must explicitly specify which atoms are aligned.

The Pair Fitting Wizard

The Pair Fitting Wizard can be launched via the "Wizard" menu. Due to a bug in the current version of the software, it may also be necessary to switch the mouse into 3-Button Editing Mode before clicking on atoms with this wizard.

To use this wizard, simply click on each pair of atoms, starting each pair with the atom in the mobile object followed by the atom in the target object. Once three or more pairs have been defined, one can click the "Fit n Pairs" button to perform the superposition.

The pair_fit command

The key thing to remember with the "pair_fit" command is that the selections provided must contain exactly the same number of atoms. Also note that no spaces are permitted within selection macros. The following example "pair_fit" command superimposes the CA atoms for residues 480 to 482 and 528 to 531 in chain A of "1uwh" onto the CA atoms of residues 621 to 623 and 670 to 673 in "1t46".

pair_fit 1uwh//A/480−482+528−531/CA, 1t46///621−623+670−673/CA
Creating and Editing Molecular Objects

One thing that sets PyMOL apart from other molecular viewers is its capacity to support changes made to the molecular structure during visualization. However, the current user interface for performing such changes is incomplete and under development, and there is no facility within PyMOL for performing geometric optimization or energy minimization of arbitrary structures. Thus, PyMOL can really only be used as a de-novo molecular builder in combination with an external tool, such as Schrodinger's Batchmin or OpenEye's Szybki. Without such tools, PyMOL is limited to making simple changes such as adding or removing hydrogens, eliminating atoms which currently exist, or adding trivial substituents on to existing ligand structures.

Removing Unwanted Atoms

PyMOL provides a quick way of removing waters or hydrogens: simply click on the Actions (“A”) menu next to the object and select "remove hydrogens" or "remove waters".

You can also remove a specific atom, residue, chain, segment, or covalent molecule from within a molecular object by right-clicking on an unselected atom in the graphics area to display the atom's default pop-up menu, following the desired level in the hierarchy, and then choosing "remove atoms".

Selections can also be used to remove groups of atoms that do not necessarily lie in the same region or object. To do this, create a selection consisting of those atoms that you wish to remove and then choose "remove atoms" from the Actions ("A") menu for that selection.

Finally, you can use the "remove" command to specifically eliminate a specified set of atoms. For example, to remove chains B and Y in PDB structure 1uwh, one could enter the following command:

```
remove /1uwh//B+Y
```

Changing Bond Valences

One of the major problems with PDB files is that they do not contain bond valences for ligands. As a consequence, it is not possible to display correct chemistry for ligands, and PyMOL may not always recognize the correct hydrogen–bonding interactions between proteins and ligands until the valences have been properly specified.

To edit bond valences, you must first switch the mouse into 3–button editing mode and activate display of valences. The easiest way to perform both actions is to click on the "Builder" button in External GUI.

Next, CTRL–right–click to pick the bond whose valence you wish to change. You should see a white band appear about the bond. You can now cycle through the available bond valences by clicking on the "Cycle" button in the Builder area of the External GUI, by selecting "Cycle Bond Valence" from the Builder menu, or...
by pressing CTRL−W. Once you have set the correct valence for that bond, you can CTRL−right−click to select the next bond to fix and then continue the process until all valences have been fixed.

Note that PyMOL currently adds missing hydrogens to the atoms involved in the bond. If hydrogens are not desired, use the "remove hydrogens" item from the Actions ("A") menu for the object after correcting all of the bond valences.

Rotating Bond Torsions

Bond torsions can be rotated by CTRL−right−clicking−and−dragging near the mobile end of the bond. Once a bond has been picked, you can also rotate the atoms on either end of the bond by CTRL−left−clicking−and−dragging. If you make a mistake, CTRL−Z will undo recent conformational changes.

Creating or Removing Bonds

Bonds can be formed by picking two atoms sequentially and then selecting "Create Bond" from the "Build" menu in the external GUI or by pressing CTRL−T. Once a bond has been created, the valence can be changed as described above.

To delete bonds, they must first be picked in the same manner as described above for changing valences. The picked bond can then be deleted by pressing CTRL−D or by hitting the Delete key.

Creating One Object Out of Another

Atoms contained in a selection can be copied into a new object by choosing the "create object" option from the Actions ("A") menu for the selection. A new object name will appear in the names list, and you can then rename this object using its Actions ("A") menu. Atoms in a newly created object can be manipulated independently from those in the source object(s).

Mutating Protein Residues

PyMOL can mutate individual side chains of proteins as well as suggest alternate rotamers (conformations) for existing side chains. Such actions are performed using the Mutagenesis Wizard.
To launch the Mutagenesis Wizard, select "Mutagenesis" from the "Wizard" menu in the External GUI. Then click on the side chain you wish to alter. Initially, PyMOL will load the set of common rotamers for the existing side chain, in the order of most frequent occurrence. You can use the left and right arrow keys or the VCR controls to step through the side chain rotamer conformations. To choose a different residue type for mutation, click on the first pop-up menu that will initially be set to "No Mutation".

Once you have chosen the mutation and set the desired rotamer, click the "Apply" button in the internal GUI. When you are finished making mutations, click "Done".

**Building Small Molecules**

NOTE: Until PyMOL can be equipped with a geometric optimization capability, we recommend that you use external tools to build molecules (such as Chem3D) and then import them into PyMOL for visualization.

PyMOL’s molecular builder is based on constructing molecules one atom or one fragment at a time. In general, you first pick an atom, typically a hydrogen, and then replace that atom with a fragment consisting of either a new atom or a new fragment with attached hydrogens. The process is then repeated until the molecule is completely built.

Rings can be formed by creating a new bond between two existing atoms in the molecule. However, without an external optimization tool, it is nearly impossible to build cyclic conformations in PyMOL at the present time. Thus, PyMOL is currently limited in its utility as a general-purpose molecular builder.
Scenes and Shows

PyMOL "Scenes" make it possible to store a series of molecular views, each with their own colors, visible representations, and camera positions. Scenes are organized into a sequence, much like the slides of a PowerPoint presentation. When playing back scenes, PyMOL will interpolate the camera view between them in order to provide a continuous sense of 3-dimensional context for the viewer.

To see how a PyMOL "Show" works, double-click the "demo_show.psw" file and use the Page Down (PGDN) and Page Up (PGUP) keys to step through the presentation. Note that you can manipulate the view using the mouse anytime you want without corrupting the presentation.

Creating and Viewing Scenes

To create a Scene, click "Append" from the "Scene" menu in the External GUI. PyMOL will automatically assign a name to the Scene that can be used to refer to it (eg. "001"). You can then change the view and/or the way that molecules are displayed and then append additional scenes as desired to create your presentation.

Once two or more scenes have been defined, the "Next" and "Previous" options in the "Scene" menu can be used to advance forward or backward through the scenes. However, the most convenient way to do this is to use the Page Down (PGDN) and Page Up (PGUP) keys to advance forward or retreat backward, respectively. Also note that pressing CTRL–PGDN will insert a new scene after the current one, and CTRL–PGUP will insert a new scene before the current one.

Modifying, Annotating, and Saving Scenes in a Session

The last scene displayed can be updated using the "Update" item in the "Scene" menu. You can also add textual annotation to the current scene via a typed command such as:

```
scene auto, update, Some annotation information.
```

This will display "Some annotation information." on the screen the next time that the scene is recalled.

When you save a PyMOL Session, all of the scenes you have defined will be saved as well. You can then share the session file with a collaborator, and he or she will be able to open up the session file into PyMOL and view the sequence of scenes you have defined.

Creating Shows and Interconverting with Sessions

A "Show" file is simply a PyMOL Session file that contains one or more scenes and is saved with a ".psw" file extension instead of the normal ".pse" file extension. When a ".psw" file is opened, PyMOL automatically enters full-screen mode and begins with the first scene in the sequence.

To convert a Session to a Show, change the ".pse" file extension to ".psw". To convert a PyMOL Show back to a Session, change the ".psw" back to a ".pse".

If you are using Microsoft Windows and cannot see the file extension, then it may be hidden as per the Windows default configuration. To change this, open the "Folder Options..." from the "Tools" menu of the enclosing Windows folder. Under the "View" tab, make sure that the "Hide extensions for known file types" option is not checked.
Advanced Features

Saving Coordinates

PyMOL has a limited ability to write out coordinates for input into other programs. The interchange file formats supported are: PDB (Protein Data Bank), MOL (MDL MOL−file), and MMD (Macromodel). PyMOL can also save molecules in an internal PKL (Pickle) file format that is able to preserve all of the molecular information, including bond valences and atomic properties — something none of the other file formats do well.

To save a molecule, first make sure that the atoms you wish to save are contained in either a distinct object or are pointed to by a named selection. Then choose "Save Molecule..." from the File menu in the External GUI, pick the name of the object or selection in the next window, and enter the filename. Make sure that the correct file extension is appended on to the filename (e.g. ".pdb"), and then click "Save".

Probing Electrostatics

Quantitative electrostatics calculations are typically difficult and time−consuming to perform. They require the specialist skills of a computational chemist to carefully consider missing protein segments and side chain atoms, histidine ionization, and the presence of specific counter−ions from bulk solvent. Furthermore, calculations involving ligands usually require high−level quantum calculations to obtain reasonable atomic partial charges for novel scaffolds. Assuming that such issues have been addressed, PyMOL can call upon the Adaptive Poisson−Boltzmann Solver (APBS) under a Unix environment to perform quantitative electrostatic calculations. The program can also read pre−calculated potentials from the Grasp, Delphi, or Zap electrostatics solvers.

In lieu of rigorous calculations, a simple, local (but technically incomplete), quasi−Coulombic calculation can often help answer the qualitative question: "Is this region of the protein surface likely to be positive, negative, or neutral relative to the rest of the protein?" PyMOL provides such answers for proteins by performing an automated calculation which essentially amounts to smoothing out the local charge density from nearby atoms (within 10 Angstroms), without taking into account solvent screening effects.

To perform this calculation, follow the Actions ("A") menu for the protein object to item "generate" −> "vacuum electrostatics" −> "protein contact potential". After a minute or two, PyMOL will create a new object with the protein shown as an electrostatic surface colored blue in the positive regions and red the negative regions. You can then CTRL−click−and−drag along the slider to change the color levels.
Atom Selection Syntax

PyMOL has a powerful atom selection language that is covered in-depth in the PyMOL Users Manual. Here we provide some simple example selections that you can hopefully adapt for your needs:

1. To select a numbered residue in a specific object (e.g. 1t46):
   
   `select my_resid, 1t46///640/`

2. To select all residues with a given identifier in any object:

   `select my_resids, 606/`

3. To select specific residues and ranges of residues by identifier:

   `select my_range, 601-610/`
   `select my_resids, 1t46///602+606+601-610/`

4. To select specific residues by residue type:

   `select my_negative, 1t46///GLU+ASP/`

5. To select specific atoms by name:

   `select my_main_chain_atoms, 1t46///N+CA+C`

6. To select one or more chains:

   `select my_chain, A+B//`
   `select my_chains, 1uwh//A+B//`

7. To select atoms in multiple objects

   `select my_object, 1uwh///CA or 1t46///CA`

Automating with Scripts

Scripts are text files that contain a sequence of PyMOL commands, and they can be used to perform repetitive tasks automatically. For example, if you wish to prepare a series of standardized figures, but would like to use a different crystal structure for each figure, then it would make sense to use a script to perform some or all of the figure preparation tasks automatically.

To run a script, select "Run..." from the "File" menu in the external GUI, or type "@" followed by the filename path into a command line.

The following example PyMOL command script contains six commands that color and represent the target and ligand in a standard way. To use a different input structure with this script, you would just update the first command in the file with a new PDB filename.

```py
# load a PDB file
load kinases/1t46.pdb

# show the ligands as space-filling spheres
```
In addition to command scripts, PyMOL can also be controlled using the Python programming language, which also makes it possible to create custom applications that integrate PyMOL for molecular visualization.

**Creating Movies**

Scenes are by far the easiest way to generate animated effects from within PyMOL, but they are limited to real–time visualization from within the program. Movies are more general, but they often require some programming as well as extra image processing work to generate a standalone movie file.

```python
# load a structure and apply the "simple" preset
load kinases/1t46.pdb
preset.simple()

# define a 360 frame movie, consisting of simple Y axis rotation loop
mset 1 x360
movie.roll 1, 360

# start the movie
mplay
```

From within PyMOL, movies can be stopped and started using the VCR controls in both the external and internal GUls. To create a standalone AVI, QuickTime, or GIF movie file, additional steps are required. On a Macintosh, the movie can be written out directly as a QuickTime movie. On other platforms, it is necessary to save the individual frames and combine them using external software, such as ImageMagick or Adobe Premiere.
Saving QuickTime Movies with MacPyMOL

MacPyMOL has the ability to directly write QuickTime movies directly. Once you have defined a movie as described above, select "Save Movie As..." from the "File" menu and choose "QuickTime...". Then set the "Frames per second:" to 30, uncheck the "Keyframe" and "Limit data rate" options, and adjust the quality to "High".

![Compression Settings]

Then click the "Ok" button and select the destination location and filename for the movie. Once you click "Save", MacPyMOL will begin the process of creating the movie. Note that MacPyMOL will not respond or update the screen while it is working. To confirm that MacPyMOL is indeed working, you can verify that the size of the movie ".tmp" file in the destination folder is steadily increasing. MacPyMOL will become responsive again once the movie has been completed (typically within a few minutes).

By default, MacPyMOL renders movies using OpenGL. If you prefer that they be ray-traced, then issue the command:

```
set ray_trace_frames
```

before performing the steps above. Note that ray-traced movies can require several hours of computing time to create.
Next Steps

Once you have mastered the basics covered in this PyMOL tutorial, you may wish to expand your knowledge by tapping some internet resources:

**Joining the PyMOL–Users Mailing List**

As of Fall 2005, almost 1,000 PyMOL users subscribe to the pymol–users mailing list, which is where the community exchanges tips on how to use the software effectively and how to solve any problems that come up. To join the mailing list, click on the "MailList" item at the top of the PyMOL Home Page (http://www.pymol.org).

**Visiting the PyMOL Wiki Community Web Site**

The community also runs a "Wiki" dynamic content site that aggregates information from the mailing list and provides other kinds of PyMOL–related documentation (http://www.pymolwiki.org). PyMOL users can create their own pymol–related pages on this site or elaborate upon useful information that is already posted.

**Accessing the Online Manuals**

The official PyMOL manual tends to lag somewhat behind the current version of PyMOL. Nevertheless, they still have much useful information on topics such as PyMOL commands and the atom selection syntax. The current manuals can be accessed by clicking on the "Manual" item at the top of the PyMOL Home Page (http://www.pymol.org).
Installing PyMOL

The PyMOL installation process is slightly different for each platform.

Precompiled Executable Builds

PyMOL is available from DeLano Scientific LLC in a precompiled form for common Windows, Linux, and Macintosh systems. If you do not have one of these systems, then it will be necessary to compile it from the open source code.

If you have a Windows PC

Hardware

• A "wheel" mouse.
• A graphics card that supports OpenGL (e.g. GeForce, Radeon, Quadro, or FireGL).

Software

• PyMOL requires Microsoft Windows 2000 or Windows XP.
• pymol−X_XX−bin−win32.zip can be downloaded from http://www.pymol.org. Note that the X_XX in the preceeding file name corresponds to the PyMOL version number (which changes over time).

Installation

1. Open the Zip archive and extract the pymol−X_XX−bin−win32 folder to a convenient location (such as the Windows desktop).
2. Open the pymol−X_XX−bin−win32 folder.
3. Launch the setup.exe program.
4. Answer questions asked or click "Next" as appropriate to complete the installation.

Testing

1. Launch "PyMOL" from the Start menu under "All Programs".
2. Once the software has started up, select "Demo" from under the "Help" menu in the upper−right−hand side of the window.
3. Confirm that your screen looks similar to the image shown here.
4. Using the left mouse button, click and drag the pointer on the rainbow colored protein to confirm that PyMOL is responsive.
5. Select "Quit" from the "File" menu to leave the program.
If you have a Macintosh

Hardware

- A "wheel" mouse.

Software

- PyMOL requires MacOS X 10.3 (Panther) or MacOS X 10.4 (Tiger).
- `macpymol–X_XX.tar.gz` can be downloaded from http://www.pymol.org. Note that the X_XX in the preceding file name corresponds to the PyMOL version number (which changes over time).

Installation

1. Most Macintosh web browsers will automatically uncompress and extract the MacPyMOL application from the "tar.gz" archive. If that has not happened, then select `macpymol–X_XX.tar.gz` and choose "Open" from the "File" menu to extract it.
2. Drag the MacPyMOL application to the Applications folder or a similarly convenient location on your hard disk.

Testing

1. Launch PyMOL by double-clicking on the MacPyMOL icon.
2. Once the software has started up, select "Demo" and the "Cartoons" from under the "Wizard" menu.
3. Confirm that your screen looks similar to the image below.
4. Using the left mouse button, click and drag the pointer on the rainbow colored protein to confirm that PyMOL is responsive.
5. Select "Quit" from the "File" menu to leave the program.
If you have a Linux PC

Hardware

• A "wheel" mouse.
• A graphics card that supports OpenGL from a vendor that provides Linux drivers (e.g. nVidia, ATI, or 3DLabs).
• An x86–compatible CPU (if not, then you must compile from source).

Software

• PyMOL should run with any Linux based on the GNU C library, version 2.3 or greater.
• PyMOL requires installation of the accelerated OpenGL graphics drivers for your specific graphics hardware.
• pymol−X_XX−bin−linux−x86−glibc23.tgz can be downloaded from http://www.pymol.org. Note that the X_XX in the preceeding file name corresponds to the PyMOL version number (which changes over time).

Installation

1. Extract the archive

tar −zxf pymol−X_XX−bin−linux−x86−glibc23.tgz

to create a pymol directory.
2. Run the setup script from within the new directory

    cd pymol
    ./setup.sh

    to create a pymol launch script.

Testing

1. Launch "PyMOL" by typing

    ./pymol

    from within the pymol directory.
2. Once the software has started up, select "Demo" from under the "Help" menu in the upper–right–hand side of the window.
3. Confirm that your screen looks similar to the image below.
4. Using the left mouse button, click and drag the pointer on the rainbow colored protein to confirm that PyMOL is responsive.
5. Select "Quit" from the "File" menu to leave the program.